mbdirnotify/flake.nix

20 lines
640 B
Nix

{
description = "Sends notifications for emails stored in maildir";
inputs = { nixpkgs.url = "github:nixos/nixpkgs?ref=nixos-unstable"; };
outputs = { self, nixpkgs }:
let
system = "x86_64-linux";
pkgs = import nixpkgs { inherit system; };
in {
devShells.${system}.default = pkgs.mkShell {
packages = [ pkgs.rustc pkgs.cargo pkgs.rust-analyzer pkgs.rustfmt ];
};
packages.${system}.default = pkgs.rustPlatform.buildRustPackage {
pname = "mbdirnotify";
version = "0.0.1";
cargoLock.lockFile = ./Cargo.lock;
src = pkgs.lib.cleanSource ./.;
};
};
}